Removal of PHP 5.6 and PHP 7.0 in EasyApache Profiles

Both PHP 5.6 and PHP 7.0 reached End of Life at the beginning of the year, and are no longer receiving any security patches from PHP. With cPanel & WHM Version 80 moving to the current tier, we are also encouraging users to upgrade to supported PHP versions in EasyApache 4. To help with that, we are removing PHP 5.6 and 7.0 from our default EasyApache profiles. This change only impacts servers running our default EasyApache profiles currently, but we are planning on removing PHP versions 5.6 and 7.0 from our EasyApache 4 repositories entirely by Version 88 (anticipated in the second quarter of 2020).

If your server is currently using PHP versions 5.6 or 7.0, you will not be affected unless or until the EasyApache 4 profile on your server is updated or reinstalled. 

What does this mean to me?

As both of these versions have been End of Life since the beginning of 2019, these versions are no longer supported or receiving updates from the providers of PHP. If you or your customers are currently running websites using either PHP 5.6 or 7.0, this is a good opportunity to encourage an upgrade to PHP 7.2. Any sites continuing to use these PHP versions are at risk for potential security or compromise issues. If moving from versions 5.6 or 7.0 is impossible, CloudLinux provides updated and patched versions of PHP that have reached End of Life. If CloudLinux is not an option for you or your customers, there is the option to create a custom EasyApache 4 profile and continue to use PHP 5.6 and 7.0, but we do not recommend it.

How do I prepare?

Ensuring that you or your customers have updated their software to use PHP 7.2 (or higher) is a great way to start. Popular CMSs such as WordPressJoomla, and Drupal provide instructions on how to update their versions to those that support PHP 7.2 (WordPress version 5+, Joomla version 3.9, and Drupal version 8.7.1).

If you need to check which of your domains are currently running either PHP 5.6 or 7.0, you can use the API call php_get_vhost_versions. If you’d like to use the Command Line API tools your command would look like this:

whmapi1 php_get_vhost_versions | grep -A1 version: 

The results will look similar to this: 

[root@server ~]# whmapi1 php_get_vhost_versions | grep -A1 version:
      version: ea-php70
      vhost: dnstest.com
--
      version: ea-php71
      vhost: example.com
--
      version: ea-php70
      vhost: cptest.com
--
      version: ea-php70
      vhost: test.com
--
      version: ea-php71
      vhost: thisisatest.com

This API call, with some modification, has the potential to tell you which domains are running which versions of PHP, thereby identifying them as candidates for upgrading their PHP versions, as well as potentially the software those accounts are also running.

Have any questions?

If you are unsure of what to do next, or want to discuss these changes further, please join us in our Slack or Discord channels, or join us on our official cPanel subreddit

Posted by Web Monkey

Leave a Reply